Apple Safari 12 has removed NPAPI plugins for IP cameras

It appears that Apple Safari V12 no longer supports the NPAPI plugins that many IP camera manufacturers rely upon for browser support to view their cameras.

Please keep your camera firmware up to date. If you have trouble using Safari to view the Foscam cameras or NVR,  please download and install Video Management software for your OS from Foscam Official website:

https://foscam.com/downloads/app_software.html

Currently the Foscam models with Ambarella chips will work with Safari 12 web browser. Such as C2, R2, R4, FI9900P, FI9900EP, FI9901EP, FI9928P, FI9961EP. Please update your camera firmware to the latest and install the new plugin.